Editor
Owner’s Manual
❏ Special Notices
• The software and this owner’s manual are the exclusive copyrights of Yamaha Corporation.
• Copying of the software or reproduction of this manual in whole or in part by any means is expressly forbidden
without the written consent of the manufacturer.
• Copying of the commercially available music sequence data and/or digital audio files is strictly prohibited except
for your personal use.
• Yamaha makes no representations or warranties with regard to the use of the software and documentation and
cannot be held responsible for the results of the use of this manual and the software.
• The screen displays as illustrated in this owner’s manual are for instructional purposes, and may appear somewhat different from the screens which appear on your computer.
• Future upgrades of application and system software and any changes in specifications and functions will be
announced separately.
• The company names and product names in this Owner’s Manual are the trademarks or registered trademarks of
their respective companies.
YAMAHA PRO AUDIO GLOBAL SITE
http://www.yamahaproaudio.com/
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Getting Started
Description of menus and buttons
In the event that menu and button names on the Windows system are different from those on the Macintosh system, this manual uses the Windows menu and button names followed by the Macintosh menu and button names
in parentheses.

Getting Started

SPX2000 Editor enables you to remotely control the SPX2000 unit and to save the effects on your computer.
To use SPX2000 Editor, you must follow these steps:
> Start Studio Manager.
> Configure the SPX2000 Editor.
> Synchronize SPX2000 Editor with your SPX2000 unit.
For more information on using Studio Manager, refer to the Owner’s Manual for Studio Manager.

Using SPX2000
Editor Windows

Configuring the Editor
You must configure the following settings for each open Editor.

❏ System Setup

Appendix

To open the Setup window, choose [System Setup] from the [File] menu.
Be sure to specify the Input port and Output port.

Input port/Output port : These pop-up menus are used to select the ports through which SPX2000 Editor
will communicate with your SPX2000 unit.
NOTE

Specify a MIDI port in the Studio Manager before selecting the Input port/ Output port.

EDITOR ID : SPX2000 Editor can control any one of up to eight SPX2000 Professional Multi-Effect Processors,
each with its own exclusive ID. Select the ID of the SPX2000 unit you want to control.
NOTE

You must set the Editor ID to the same ID number as you specified in your SPX2000 unit.

Confirmation : These options determine whether or not a confirmation dialog box appears when storing or
recalling.
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❏ Input Signal Setup

Getting Started

To open the Input Signal Setup window, choose [SPX Setup] from the [File] menu.

Input Source : Select a input source: Analog or Digital
Input Mode : Select a input mode: Monaural or Stereo

1 Choose [Re-synchronize] from the [Synchronization] menu.
The following window opens.

2 Select whether you want to transfer your settings to SPX2000 Editor, or vice versa.
At this time, the [All Libs] option determines whether or not Library data is synchronized.
[PC -> SPX2000] : Transfers the settings of the current SPX2000 Editor Session to your SPX2000 unit.
[SPX2000 -> PC] : Transfers the settings of your SPX2000 unit to the current SPX2000 Editor Session.

3 Click [OK].
Do not operate the SPX2000 unit while synchronization is in progress.
NOTE

• If you use the “Total Recall” function in Studio Manager, all selected Editors in Studio Manager are
synchronized with the corresponding devices.
• If the operation lock setting is enabled on the SPX2000 unit, parameters that are blocked will not
change on the SPX2000 unit when you operate SPX2000 Editor; this means that the parameter
settings in SPX2000 Editor and in the SPX2000 unit itself may not match.
For details on the settings that are blocked, refer to the SPX2000 owner’s manual.
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When SPX2000 Editor starts up for the first time, the parameter settings on the SPX2000 unit and the parameter settings in SPX2000 Editor be different. Therefore, you must first match the parameter settings on the SPX2000 unit
with those in SPX2000 Editor. This operation is called “synchronization.” Follow the steps below to synchronize
SPX2000 Editor.

Using SPX2000
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Synchronizing SPX2000 Editor

Offline Edit Function
If you do not want to synchronize your SPX2000 unit with SPX2000 Editor, select [Offline Edit] from the [Synchronization] menu. The Offline Edit function is also activated when you click the [ONLINE]/[OFFLINE] button in the
Effect Editor window.
To apply your off-line edits to your SPX2000 unit, synchronize the SPX2000 unit with SPX2000 Editor.
Some parameters in the SPX2000 unit change their displayed values depending on the sampling
frequency. If you switch SPX2000 Editor from OFFLINE to ONLINE, displayed parameter values may
change because SPX2000 Editor loads the sampling frequency from the SPX2000 unit and updates
the display.

Getting Started

NOTE

Working with Sessions

Creating a new Session

Choose [New Session] from the [File] menu.

Opening a previously saved Session

Choose [Open Session] from the [File] menu.

Saving the current Session

Choose [Save Session] from the [File] menu.

Saving the current Session with a new name

Choose [Save Session As...] from the [File] menu.

If you save a Session in the SPX2000 Editor window, only that Editor’s settings are saved in a file with a file extension
of “.SPX”.
If you save a Session in the Studio Manager, all selected Editor settings are saved in a file with a file extension of
“.YSM”.
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All of the settings in SPX2000 Editor, including the library data, are collectively called a “Session.” The following table
describes how to handle Sessions.

In SPX2000 Editor, you can cancel the latest operation (Undo) and also cancel the cancellation of the latest operation
(Redo). If you perform an Undo operation twice in a row, you can cancel the two most-recent operations. If you perform an Undo operation three times in a row, you can cancel the three most-recent operations. In this way, you can
cancel multiple recent operations. The following table describes how to use the Undo/Redo function.
NOTE

To cancel (i.e., Undo) the most recently-performed operation in the Library window, click the [Undo]
button in the Library window. You cannot execute [Undo]/[Redo] commands from the [Edit] menu.
For details, refer to page 5.

Undo

Choose [Undo] from the [Edit] menu.

Redo

Choose [Redo] from the [Edit] menu.

Please note, however, that after you perform one of the following operations, you cannot successfully undo or redo
any previous operation:
• Closing Studio Manager
• Synchronizing your console or device with Studio Manager
• Creating a new Session
• Opening and closing a Session
• Saving a Session
• Recalling a effect
NOTE

You cannot Undo or Redo the following operations:
• Edits in the Setup window
• Synchronization
• Opening and closing the windows
• Resizing the windows
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Undo/Redo Function

Using SPX2000 Editor Windows
Library Window
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Getting Started

The Library window enables you to manage libraries (parameter settings for each effect). In addition, libraries can be
saved to disk on your computer as Library files.
To open the Library window, choose [Library] from the [Windows] menu.
The Library window consists of two panes. The pane on the left, called the [FILE] section, displays the contents of the
SPX2000 Editor library file. The pane on the right, called the [INTERNAL DATA] section, displays the Effect list of
the SPX2000 unit.
You can copy and sort the items (effects) in the list by dragging them between the panes. Within the same pane, you
can copy an effect by dropping it on top of another effect, and you can sort effects by dropping an effect between two
effects. Effects can be swapped by holding down the <Shift> key while dragging. In all cases, the contents of the destination effect are overwritten. To edit a effect title, click the title, then type. To select multiple effects, click effects
you want to choose while holding down <Shift> key or <Ctrl> key (< >).

%
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1 File name

This is the file name of the currently open Library file.

2 [OPEN] button

This button is used to open Library files.
NOTE

DM2000/02R96/DM1000/01V96 library files with the “.D2E” extension can also be opened, but
some files may not be compatible with SPX2000 Editor. (see page 11)
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3 [CLOSE] button

This button is used to close the currently open Library file.

4 [SAVE] button

This button is used to save the currently open Library file.
NOTE

You should normally save files with the “.SPE” extension. If you want to save a file in a form that can
be opened by the DM2000/02R96/DM1000/01V96, you should save it with the “.D2E” extension.

5 [SAVE AS] button

This button is used to save the currently open Library file with a different name.
You should normally save files with the “.SPE” extension. If you want to save a file in a form that can
be opened by the DM2000/02R96/DM1000/01V96, you should save it with the “.D2E” extension.

Getting Started

NOTE

6 TITLE

This column displays the effect titles.

7 PROTECT

This column displays padlock icons

for protected effects. It also displays an

(read-only) icon for preset data.

8 [FILE] section

This section displays the contents of the SPX2000 Editor library file.
This section displays the effect list of the SPX2000 unit.
NOTE

If the OFFLINE indicator is selected by the [ONLINE]/[OFFLINE] button in the Effect Editor window,
SPX2000 Editor is not synchronizing with the SPX2000 unit. Therefore, this section does not display
the SPX2000 unit’s correct setting.

) Bank select buttons

Click one of the [PRESET/CLASSIC/USER] buttons to see the effects that are stored in the corresponding bank.

! [STORE] button

Using SPX2000
Editor Windows

9 [INTERNAL DATA] section

This button stores the current settings into the selected effect (location).

@ [RECALL] button
NOTE

If you recall an effect from the FILE section of the Library window, the display background color in the
SPX2000 unit and the LCD color in SPX2000 Editor may differ. In this case, copy the effect into the
INTERNAL DATA section, and then recall it.

# [CLEAR] button

This button clears the selected effect from the list.

$ [UNDO] button

This button undoes the last recall, store, copy, clear, sort, titling, protect or color select operation.
Note: In the Library window, you can undo only the most recent operation. You cannot undo any operations performed prior to the most recent operation.

% LCD color select

This lets you change the background color of the SPX2000 unit’s display for each effect that is recalled. You can
change the background color only for USER bank effects. You can choose one of five colors.

^ [PROTECT] button

This button is used to protect or unprotect the selected effect.
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This button is used to recall the selected effect.

Effect Editor Window
The Effect Editor window lets you edit effect parameters.. To open the Effect Editor window, choose [Effect Editor]
from the [Windows] menu.
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Getting Started

1

The EFFECT NAME, TYPE, and IN/OUT are the name, type and I/O configuration of the effect
recalled to the currently selected effects processor. To edit the EFFECT NAME, click it and type. The [LIBRARY]
button opens the Library window.

2 [COMPARE] button/indicator

The [COMPARE] button will light when you edit a parameter after recalling an effect. To compare the result of
your editing with the un-edited effect settings, click the lit [COMPARE] button. (The indicator at left will light.)
The [COMPARE] button and indicator will go dark when you store or recall an effect.
NOTE

• If you recall an effect from the FILE section of the Library window, pressing the [COMPARE] button
will compare that effect with the effect prior to recall.
• While you are comparing the result of your editing with the un-edited effect settings, other
operations in SPX2000 Editor cannot be performed.

3 [ONLINE]/[OFF LINE] button

Repeatedly clicking this button toggles between online and offline status.
NOTE

If SPX2000 Editor is not connected or is not communicating with the SPX2000 unit, clicking this
button will not switch the SPX2000 unit from offline to online.

: This indicator is displayed when SPX2000 Editor is connected to the SPX2000 correctly. If the connection is correct, the SPX2000 Editor parameters will work in unison with the SPX2000 unit parameters.
: This indicator is displayed when SPX2000 Editor is not connected or is not communicating with the
SPX2000 unit, or when you have selected Offline Edit. If the connection is incomplete, the SPX2000 Editor
parameters will not work in unison with the SPX2000 unit parameters.
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1 Effect select section

4 LCD color

For each effect that is recalled, this indicates the background color of the SPX2000’s display. For USER bank
effects, you can use [LCD color select] in the Library window to change the background color.

5 [IN] button

This button is used to set the metering position to the effects processor’s inputs.

6 [OUT] button

This button is used to set the metering position to the effects processor’s outputs.

7 Level Meters

SPX2000 Editor displays the effect input level or output level.
Getting Started

8 Effect parameter section

This section contains the various effects controls, buttons, and displays. Its layout depends on the selected effect
type.

9 [MIX BALANCE] knob

This knob enables you to adjust the balance between the wet and dry signals. When set to 0, only the dry signal is
heard. When set to 100, only the wet signal is heard.

) [BYPASS] button

! PLAY/REC section

This window is displayed only if the FREEZE/FREEZE A/
FREEZE B effect type is selected. To begin recording (sampling), click the REC button and then click the PLAY button.
The progress bar lets you to check the currently recording
position. To play back the recorded sample, click the PLAY
button.

REC button
Progress bar
PLAY button

Using SPX2000
Editor Windows

This button is used to bypass the currently selected effects processor.

The TEMPO parameter is displayed only if an effect type that includes the TEMPO parameter is selected. Select
one of the three buttons below to choose how the TEMPO parameter will be set.
[VALUE ONLY] : You can set the TEMPO parameter by
using the rotating knob.
VALUE ONLY button
[MIDI CLK] : You can set the TEMPO parameter by using
MIDI CLK button
the rotating knob and by MIDI clock messages from an exterTAP button
nal device.
TAP TEMPO button
[TAP] : You can set the TEMPO parameter by using the rotating knob or the [TAP TEMPO] button.
Rotating knob
[TAP TEMPO] : Repeatedly click the [TAP TEMPO] button
to set the TEMPO parameter to the corresponding interval.

# SOLO section

This window is displayed only if the effect type M.BAND
DYNA is selected. The SPX2000 unit will output only bands
that are turned ON. If you turn all three buttons to ON, all
bands will be output.
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@ TEMPO section

REV-X Window
When a REV-X effect is recalled, one of the three windows REV-X HALL, REV-X ROOM, or REV-X PLATE will be
displayed. If a REV-X effect is recalled, you can also display the REV-X window by selecting [REV-X] from the [Window] menu.
• The REV-X windows are only for REV-X effects. If the recalled effect is not a REV-X effect, these
windows won’t be displayed.
• If you change a parameter setting in the REV-X window, the setting in the Effect Editor window will
change accordingly.
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1 EFFECT TYPE

Appendix

The effects type appears here.

2 [OPEN/CLOSE]

Click here to open or close the parameter window.

3 [Reverb Time]

Duration of time over which the reverberation decays to silence. Higher values extend the reverberation. Drag the
icon to change the value.

4 [Initial Delay]

Duration of time between sound input and the start of reverberation. Higher values delay the start of reverberation. Drag the icon to change the value.

5 [Decay]

Shape of reverberation envelope. Reverberation characteristics are determined by the value. Drag the icon
change the value.

to

6 [Room Size]

Size of space. Higher values simulate larger spaces. This value is linked with the Reverb Time value. When you
change this value, the Reverb Time value changes. Drag the icon to change the value.

7 [Diffusion]

Density and spread of reverberation. Higher values increase the density and enhance the spread. Drag the icon
to change the value.
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8 [HPF]

This filter cuts the low frequency range of the reverberation. The range below the frequency specified by this value
is cut. This filter does not affect the original source sound. Drag the icon to change the value.

9 [LPF]

This filter cuts the high frequency range of the reverberation. The range above the frequency specified by this
value is cut. This filter does not affect the original source sound. Drag the icon to change the value.

) [Hi Ratio]

Length of reverberation in the high frequency range. The reverberation duration of the high frequency range is
expressed as a ratio relative to Reverb Time. Drag the icon to change the value.
Getting Started

! [Lo Ratio]

Length of reverberation in the low frequency range. The reverberation duration of the low frequency range is
expressed as a ratio relative to Reverb Time. Drag the icon to change the value.

@ [Low Freq]

Frequency value that serves as the basis for the Lo Ratio value. The frequency band below this value is affected by
the Lo Ratio parameter setting. Drag the icon to change the value.

# Filter Frequency Response Curve
$ Reverberation images

These images represent the high-range (10kHz), mid-range (1kHz), and low-range (100Hz) reverberation. These
images change shape depending on the parameter values. The vertical axis represents the level; the horizontal axis
represents reverb time; the shape represents the envelope.

% Reverb time curve

This curve represents the high-range (10kHz), mid-range (1kHz), and low-range (100Hz) reverb time. The curve
changes depending on the Reverb Time, Hi Ratio, and Lo Ratio parameter values.

Using SPX2000
Editor Windows

The curve changes depending on the HPF and LPF values.

^ [Auto Zoom] button
Click the

button to automatically adjust the time axis (horizontal axis).

Use this button to specify the time duration (in seconds) as displayed by the time axis (horizontal axis).

*[

] (Zoom Out) button

([

] (Zoom In) button

Click this button to increase the time value (in seconds) as displayed by the time axis (horizontal axis).
As a result, the display zooms out on the horizontal axis.
Click this button to decrease the time value (in seconds) as displayed by the time axis (horizontal axis).
As a result, the display zooms in on the horizontal axis.

º [INPUT]/[OUTPUT] Level meter

SPX2000 Editor displays the effect input level or output level. Use the [IN]/[OUT] buttons in the Effect Editor
window to switch between input and output level metering.

¡ [MIX] slider

This slider enables you to adjust the mix balance of the dry and wet (effect) sounds. When the balance is 0%, only
the dry sound is output. When the balance is 100%, only the wet sound is output.
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& Time Axis Set button

Appendix
Keyboard Shortcuts

Windows menu

Library window

Others

Creates a new Session

Ctrl+N

+N

Opens a previously saved Session

Ctrl+O

+O

Saves the current Session

Ctrl+S

+S

Undo

Ctrl+Z

+Z

Redo

Ctrl+Y

+Y

Closes the active window

Ctrl+W

+W

Closes all windows

Ctrl+Alt+W

+Option+W

Opens the Library window

Ctrl+4

+4

Opens the Effect Editor window

Ctrl+8

+8

Selects consecutive multiple items (effects)

Shift+click

shift+click

Selects non-consecutive multiple items (effects)

Ctrl+click

+click

Selects all effects in a section

Ctrl+A

+A

Reset the value to the default

Move the cursor to
a control or a
parameter value
and Ctrl+click

Move the cursor to
a control or a
parameter value
and +click

Getting Started

Edit menu

Macintosh

Using SPX2000
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File menu

Windows

Compatibility of “.D2E” library files
When you load an SPX2000 Editor library file into another editor or into another device, the library item numbers
will be offset by 52. (The first effect will be loaded into number 53.) Also, effects that exceed the range of user memory (effect) locations in the loading-destination device cannot be loaded.
NOTE

The library item number is offset in a similar when a library file from another editor or another device
is loaded into SPX2000 Editor. (Effect number 53 will be loaded into effect memory number 1.)

Use the following procedure to load a library file into another editor.

1 Check the number at which the user memory locations of the other editor begin.
2 In SPX2000 Editor, store the effects into memory locations that are 52 less than the
starting number you verified in step 1.
For example if the user memories are numbers 62 through 128, store the effects in numbers 10 through 76 of
SPX2000 Editor.

3 Save the data in SPX2000 Editor as a file with extension “.D2E” and then load it into
your other editor.
U.R.G., Pro Audio & Digital Musical Instrument Division, Yamaha Corporation
© 2004 Yamaha Corporation
407IP-01A0
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Action

